When that Linux Upgrade Screws Your Video Resolution

Linux Mint “just works.” I use Ubuntu quite a bit, but Mint has been my go-to Operating System for years. When I saw that 17.2 Rafaela was available in the Mint Upgrade Manager I jumped on it.

I never had a problem with Mint upgrades before, but for some reason after I upgraded to 17.2 my video resolution topped out at 1024×768.  I'm not a high-res guy anymore, but being used to 1680×1050, 1024×768 was simply not usable.

And no, I'm not talking about a NVIDIA card which is known to sometimes require some TLC. The machine I upgraded from Linux Mint 17.1 to 17.2 has an integrated Intel Video chipset. Intel video is typically found by default by both Mint and Ubuntu, and I suspect other Debian-based distributions.

I spent way too much time focusing on the Intel drivers, thinking not having the latest and greatest driver was the problem. We are waiting on an updated Intel Graphics Installer for Ubuntu 15.04, after all. The current installer wouldn't recognize Linux Mint 17.2, so perhaps this will be fixed in the future.

Post Update

You may be having other weird issues that I discovered I had after writing this post. In my case the xserver-xorg-video-intel was causing problems because somehow a VMWare video driver was being used, which meant that software rendering was occurring. It was as if my desktop was a Virtual Machine. Not Good! To see if you have similar issues run the following command:

$ glxinfo | grep OpenGL

You should see something like the following.

daveburke@Acer ~ $ glxinfo | grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Mobile Intel® GM45 Express Chipset
OpenGL version string: 2.1 Mesa 10.1.0
OpenGL shading language version string: 1.20

If the vendor string says “VMWare, Inc” instead of “Intel” like mine did, my solution was to remove the xserver-xorg-video-vesa driver and reinstall the xserver-xorg-video-intel driver in the Linux Mint Software Manager.

Back to real time….

First thing to do, if you installed the xserver-xorg-video-intel PPA like I did, remove it, otherwise the fix I found won't work for you.

The Fix: Enter Xrandr

Before I give you the fix, here is the Ask Ubuntu thread that saved the day and will have everything I'm going to share with you here.

Calculate the Mode Lines for your display. We need these figures to set the new resolution properties later. To do that we'll use the CVT utility. (Coordinated Video Timing.) Enter the width, height and refresh rate. You need to know the refresh rate, though it is usually 60. I'm not responsible if you use 60 and your monitor has another rate…or if anything else bad happens as a result of these commands, for that matter. :-) The following figures are the ones I used for my particular desktop configuration.

Now we have our mode line info. With that we'll use the Xrandr xserver utility to add a new video mode and then set it as our video mode.

$ xrandr --newmode "1680x1050_60.00"  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync

Now we add the mode and set it as our output. On my system the output is “VGA-0.” If you don't know your video output handle (and who does?) enter xrandr at the command line to view your output options.

$ xrandr --addmode VGA-0 1680x1050_60.00

$ xrandr --output VGA-0 --mode 1680x1050_60.00

If you screw up something here you should still be okay because the resolution settings will return back to what they were previously on your next login. To set the resolutions permanently in Linux Mint, add the xrandr lines you entered to the /etc/gdm/Init/Default file.

More Like This Post