When Your Solr Admin Dashboard Won't Load

I thought it was time I upgraded my Solr Server from v4.8.1 to the current version of 5.3.1. There were a few glitches along the way but the only issue that really bit me was loading the Admin Dashboard from my local Standalone Solr Url of http://solr. Loading from Tomcat at http://tomcat/solr worked just fine.

Here's what we wanted.

But instead we got this.

The thing is, I blogged about configuring Solr with Tomcat before. I scanned the post but didn't read it to the end where I mentioned this specific issue. So I thought I needed to write a blog post just on loading the Admin Dashboard from a Standalone Solr Url like http://solr.

If Solr is loading through the Tomcat Manager then you're good to go. Read the previous post for details on configuring Solr with Tomcat if you're still having issues.

The Fix

The fix is a simple matter of setting the Solr webapp Context Path as we can see in the Tomcat Localhost Access Log file. /solr/solr? I don't think so!

That Context Path is set in the Solr Webapp's admin.html page.

Because of how we're using Apache Mod Proxy with a http://localhost:8080/solr through Tomcat our Context Path is /solr. That works fine in http://tomcat/solr, but not http://solr.

We're simply going to edit admin.html and clear out that sucker.

The result is a zippily-loaded Solr Admin Dashboard in both http:tomcat/solr and http://solr.

Note to self: Next time I upgrade Solr, go to my blog and search “When Solr Admin Dashboard Won't Load…”

Posted October 05, 2015 04:31 PM EDT

More Like This Post